Ethernetkarte für Macintosh Performa 5400

Da ich mal ausprobieren möchte, wie gut man noch mit Mac OS 8.6 ins Internet kommen kann, habe ich versucht, meinen Performa 5400 von 1996 mit einer Ethernetkarte zu versorgen (serienmäßig hat der nur eine AppleTalk-Netzwerkschnittstelle und einen [sic!] Analog-Modem), um ihn in mein lokales Netz einzubinden. Da ich mir für das Experiment nicht extra eine Karte besorgen wollte, habe ich es einfach mal mit einer herumliegenden PCI-Karte aus alten PC-Beständen probiert. Also, hinten am All-In-One-Gehäuse 2 Schrauben gelöst, Kunststoffabdeckung entfernt, Schublade mit Hauptplatine am Ausklapp-Griff herausgezogen, Slotblende entfernt, Ethernetkarte in den Winkeladapter geschoben und mit dem dafür vorgesehenen Halter an der Gehäuseöffnung fixiert. Danach alles wieder fix zusammengesetzt.

Nun muss natürlich selbst für einen Mac ein passender Treiber her (mit Plug-and-Play war es 1996 noch nicht sehr weit her), der dem Betriebssystem mitteilt, dass die Netztwerkprotokolle nicht mehr nur über den LokalTalk-Anschluss, sondern auch über den neuen Ethernet-Anschluss geschickt werden können. Da ich mir vor dem Einbau ein paar Daten von der Platine der Karte abgeschrieben hatte, konnte ich nun im Internet nach passenden Treibern suchen. Leider ist es nicht selbstverständlich, dass Hersteller ihre Legacy-Treiber für schon lange nicht mehr vertriebene Hardware weiterhin zum Download anbieten – und vor allem ist nicht sicher, ob es für diese spezifische Karte überhaupt Mac-Treiber gegeben hat. Aber man kann ja auch mal Glück haben: Der Hersteller SMC hat nicht nur Treiber für das klassische Mac OS  im Angebot, sondern man kann sie sogar noch herunterladen. Und zwar hier! Weitere Treiber für Ethernetkarten anderer Hersteller kann man übrigens hier finden.

Ich habe mir also die für die Karte passenden Treiber heruntergeladen (Archiv mit Treibern für alle Systeme – da lagen sie mit drin), entpackt, auf eine CD-RW gebrannt und dann auf dem Performa 5400 installiert. Nach dem Neustart habe ich im Netzwerk-Kontrollfeld nachgesehen, ob die Karte erkannt wird (ja) und das Netzwerk-Protokoll darauf umgestellt. Sobald ich meine ersten Schritt ins Web gewagt habe, werde ich natürlich einen Erfahrungsbericht schreiben. Stay tuned …

Schreibe einen Kommentar

Trage deine Daten unten ein oder klicke ein Icon um dich einzuloggen:

WordPress.com-Logo

Du kommentierst mit Deinem WordPress.com-Konto. Abmelden / Ändern )

Twitter-Bild

Du kommentierst mit Deinem Twitter-Konto. Abmelden / Ändern )

Facebook-Foto

Du kommentierst mit Deinem Facebook-Konto. Abmelden / Ändern )

Google+ Foto

Du kommentierst mit Deinem Google+-Konto. Abmelden / Ändern )

Verbinde mit %s


%d Bloggern gefällt das: